Quantcast

TLS 1 is disabled in RDP

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

TLS 1 is disabled in RDP

Vijay Kumar Kamannavar
Hello All,

I have guacamole 0.9.2 version running. I am getting connectivity error when i tried to connect to the RDP machine where TLS1 is disabled. 

Is 0.9.2 is not supporting RDP connectivity where TLS1 is disabled ? if yes is there any suggestions to avoid it ?


Thanks,
VIjay
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: TLS 1 is disabled in RDP

Mike Jumper
On Mon, Mar 20, 2017 at 1:59 AM, Vijay Kumar Kamannavar <[hidden email]> wrote:
Hello All,

I have guacamole 0.9.2 version running.

Why such an old version?

I am getting connectivity error when i tried to connect to the RDP machine where TLS1 is disabled. 

Is 0.9.2 is not supporting RDP connectivity where TLS1 is disabled ? if yes is there any suggestions to avoid it ?


It's not Guacamole itself which implements TLS for RDP, but the underlying library (FreeRDP). I'm not aware of any bug in FreeRDP which would prevent TLS from working properly in this case, but I have not explicitly tested for this.

Do you see the same problem if you run the xfreerdp client directly? That should help narrow down whether there is indeed something Guacamole should be doing differently. If the same problem occurs when using the xfreerdp client, which uses the same underlying RDP library, then that suggests this is a bug in FreeRDP.

- Mike

Loading...